Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Pimp My Site! > Help with running Thottbot and Google searches from my Guildportal site
Tesop (New Admin) 6/3/2006 2:57 PM EST : Help with running Thottbot and Google searches from m...
Tesop
Posts: 3177
Zomgawsh Poster

I've setup a search option for both Thottbot and Google on the site. The link works fine, but if a search is entered, it looks like it runsthe search but has no where to place the results.  It doesn't openanother window, just comes back to the main page (where the searchlinks are located).

Here's the guild site

This is the code I'm using for Thootbot and Google embeded search.

<form method="get" action="http://www.thottbot.com/">
<ahref="http://www.thottbot.com/"><imgsrc="http://i.thottbot.com/Thottbotsmall.jpg"border="0"></a><br>
<input name="s" style="width: 140px;" onfocus="this.select()" type="text">
</form>

 <!-- Site-Flavored Google Search -->
<form method="get" action="http://www.google.com/search">
<table bgcolor="#ffffff">
<tbody><tr><td>
<a href="http://www.google.com/services/siteflavored.html">
<imgsrc="http://labs.google.com/images/gp/google_kaltix_site_flavored_searchbox.gif"alt="Google" align="absmiddle" border="0"></a> <inputname="q" size="31" maxlength="255" value="" type="text">
<input name="site_flavored" value="on" type="hidden">
<input name="client" value="site_flavored" type="hidden">
<input name="hl" value="en" type="hidden">
<input name="interests" value="134|65" type="hidden">
<span id="site_flavored_name"></span>
homeHTML = "<input type=hidden name=site_flavored_name value=" + document.location +">";
document.getElementById("site_flavored_name").innerHTML = homeHTML;
</script>
<input name="sa" value="Custom Search" type="submit">
<font face="arial,sans-serif" size="-1"><br> </font><br>
</td></tr></tbody></table>

<!-- Site-Flavored Google Search --> </form>

Would love to get this working. 

Any solutions?
TopBottom

Szleynix (New Admin) 6/4/2006 3:33 AM EST : RE: Help with running Thottbot and Google searches fr...
Szleynix
Posts: 2231
Zomgawsh Poster

I don't really know much about .NET, but that's was gp.com is built on and I'm pretty sure you can't have more than one form per page (there's already one for each page).

In order to get the searches working I think you should try hosting the forms off-site and then embed them using the 'embed page' content type.

Just remember to add target="_blank" to the form tag, otherwise the results will come back inside the tiny embedded page.
TopBottom

Tesop (New Admin) 6/4/2006 8:35 PM EST : RE: Help with running Thottbot and Google searches fr...
Tesop
Posts: 3177
Zomgawsh Poster

I'm afraid I don't know anything about anything it seems.  I'm sorta getting what you're saying.  Host elswhere, I get that.  Form thing, ok kinda.  Target, no idea.  Alternatives?
TopBottom

Tesop (New Admin) 6/5/2006 5:38 AM EST : RE: Help with running Thottbot and Google searches fr...
Tesop
Posts: 3177
Zomgawsh Poster

With a little reading, I managed to figure this out.

I hosted the form elswhere, as you suggested, added the target to the html.  Used embedded page, and it's perfect.

Thanks a ton.
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%