Sign Up! Login: Password: New User? Forgot? Support
Top Mods!
Wowhead Search
by sonofsamedi
Digital Clock
by Wolfar15
Admin Forums
Welcome to the GuildPortal Help Community! These forums are for admin-to-admin help.
Available Forums
Forums : Help from the Community > Links to Forum Posts - Access Denied
Valisto (New Admin) 1/8/2014 3:57 AM EST : Links to Forum Posts - Access Denied
Valisto
Posts: 393
Fingers of Fury!

So i've been trying to figure this out for about a week, and can't.

Many of my members, using a varity of browsers, are complaining that clicking links posted in the news (on our homepage) to go directly to forum posts (for more information), result in "Access Denied."  A few people had the same problem with links I posted to other pages of our website to other pages of the site.  All of the people have the access they need to view these things.  When they right click the links, and copy them, and paste them into their URL field, they get the same problem.  But they have no problems navigating to the posts and viewing them...

I've tried creating the URLs for the news posts a few different ways:
  • by going to the forum post, and copying the URL from the URL field of the browser
  • by right clicking the forum post from the list of topics and copying the URL
  • by copying the direct link from the top right of the forum post

I can't figure out what the problem is.  A few who had problems with IE11 solved their issue by using compatibiltiy mode.  But some of the people with this problem are using Firefox and Chrome.

Any advice would be appreciated...
TopBottom

Nireos (New Admin) 1/8/2014 8:57 AM EST : RE: Links to Forum Posts - Access Denied
Nireos
Posts: 14
Becoming Adept!

What access level is set on the forum the post is in?

Could you provide the web site url so we can look at it.
TopBottom

Valisto (New Admin) 1/13/2014 4:13 AM EST : RE: Links to Forum Posts - Access Denied
Valisto
Posts: 393
Fingers of Fury!

Well, like I said, everyone having this problem has the correct access level to view the posts.  They can go to them manually, and there is no problem.  

In fact, it seems they have a problem using ANY link to another page on the site, where the page or item isn't public.  Apparently they are having a problem viewing articles in the info section widget, which are not set to public, even though they have access, and can view them if they go there manually.

So it seems it may have something to do with the javascript links not accessing the cookies that store their log-in infomation maybe?  I am at a loss...  

Is anyone else having this problem?
TopBottom

Everdark (MVP) 1/13/2014 5:25 PM EST : RE: Links to Forum Posts - Access Denied
GuildPortal MVP
Everdark
Posts: 3950
Zomgawsh Poster

You can access a site using either your custom domain name (assuming you have one) or the generic www.guildportal.com URL.

For example, your site's generic address is: http://www.guildportal.com/Guild.aspx?GuildID=417109&TabID=3543953

When I hover over the links on your home page, they use this domain name.

When you log in, a cookie is created for the domain you log in with. If the links are for the "generic" domain name, and the person logs in with the custom domain and tries to view them, not having a "logged in" cookie for the generic domain, it will treat them as not logged in and give them an "Access Denied", since the access requirement was for Associate or above.

If this is what is happening, the easiest thing to do would be to change your links to the custom domain (assuming you have one), as most people would use that to get to your site. If you log in with your custom domain, all those links at the top of your forum posts will contain that same domain name.

"The person who says it cannot be done should not interrupt the person doing it." 

 
Everdark (T), Evadarr, Nevinn (AC), Soninn, Croninn, Zakarr, Avirded (SC)
TopBottom

Valisto (New Admin) 1/16/2014 4:03 AM EST : RE: Links to Forum Posts - Access Denied
Valisto
Posts: 393
Fingers of Fury!

Omg that's it!  Thank you so much!

I've been going to our site and logging in via the generic, so all the links were being made that way.

You are my hero!
TopBottom

Valisto (New Admin) 1/16/2014 9:43 AM EST : RE: Links to Forum Posts - Access Denied
Valisto
Posts: 393
Fingers of Fury!

Ok I spoke too soon....

I was able to replicate the problem for myself, and solve it this way.

But it seems this isn't working for others.

He went to the site by typing the address directly (eq2antiquity.guildportal.com)  then logged in, then clicked a link i generated logged in from that domain (giving the link the same domain), and still he gets access denied.  I asked him to clear his cookies, and try agian, and still ntohing...

TopBottom

Everdark (MVP) 1/16/2014 9:00 PM EST : RE: Links to Forum Posts - Access Denied
GuildPortal MVP
Everdark
Posts: 3950
Zomgawsh Poster

Ok, I just recreated your issue with my site based on what I noticed in your links.

When going to your site, log into your custom domain without the www in the beginning. Then recreate your links.

I logged in to mine with www, then opened a new tab and browsed to it without and it asked me to log in. The cookies are including the full subdomain, as well.

"The person who says it cannot be done should not interrupt the person doing it." 

 
Everdark (T), Evadarr, Nevinn (AC), Soninn, Croninn, Zakarr, Avirded (SC)
TopBottom

Admins Online
There are   members online.
So-and-so has logged on!
%title%
%message%